Get in touch
Back
Maintenance

WebApp maintenance

Completed 30 Apr at 03:30am CEST.

feyapp.felixschuler.at
Completed

Maintenance completed

Posted 30 Apr at 03:30am CEST.
Started

One hour maintenance due to small updates.

Posted 30 Apr at 02:30am CEST.